Thursday, June 27, 2019

Run LMMS 1.2.0 with AppImage on Ubuntu and Debian system


LMMS (Linux MultiMedia Studio) is an open source and cross-platform project designed to act as a free alternative to those popular, yet commercial and closed-source music creation applications found on Microsoft Windows and Mac OS X operating systems, such as FruityLoops, Logic, and Cubase.
State-of-the-art features

Key features include a song editor for composing audio tracks, a beat and bassline editor for generating beats and basslines, an easy-to-use piano roll for editing melodies and patterns, as well as complete computer-controlled automation sources and user-defined track-based automation.

The application has been designed from the ground up to allow users to effortlessly produce professional music under an open source GNU/Linux operating system, simply by creating and synthesizing sounds, playing live with the keyboard, and arranging samples.

A wide range of powerful effects and instruments are built into the application, allowing for unlimited audio mixing possibilities. In addition, it features a FX mixer with 64 FX channels, and support for well known standards, such as VST(i), LADSPA, MIDI, SoundFont2, and GUS patches.

New changes in 1.2.0:

  • General improvements
  • Fix build with musl C runtime library (#4825)
  • Fix debug build broken in RC8 (a233291)
  • DrumSynth: Make the parsing logic safer (#4869)
  • macOS: Disable soundio on for stability (991ffcd)
  • Allow sample track clips to be resized smaller than one bar (#4933)
  • Don't require X11Extras on Linux when VSTs are disabled (#4953)
  • Allow recording chords directly from the piano-roll (#4938)
  • Fix more issues with ZynAddSubFX and/or VSTs related to automation (#4942)
  • Better default sounds for Nescaline and Freeboy (#4968)
  • DMG rebranding (#5013)
  • UI improvements
  • macOS: Add shortcuts for inserting bars, deleting bars and deleting notes on Apple keyboard (#4851)
  • AudioFileProcessor: Better tooltip for ping-pong loop (#4868)
  • VST: Add VST always-on-top config option (17f6235)
  • VST: Ensure VST windows show properly in taskbar (6fef905)
  • VST: Don't show error when loading empty VeSTige instance (205b575)
  • Equalizer: Fix spectrum window formula (#4895)
  • Equalizer: Use brighter and more opaque colors for the spectrum view (#4772)
  • Don't draw note detuning info over the volume/panning area (#4965, 9ff882d)
  • Fix hanging cursor in piano-roll (#4960)
  • Update splash screen (#5002, #5019)
  • Bug Fixes
  • AppImage: Fix JACK detection (e54969c)
  • Fix ZynAddSubFX pitch resetting on project load/export (04768ee, 97d5529)
  • VST: Fix crash when using 32bit VSTs on 64bit Linux with VST sync turned on (3aeacca)
  • Fix crash when trying to drop controls into the empty automation editor (#4882)
  • Fix crash Ctrl + dragging patterns between instances (#4882)
  • Fix creating new ZynAddSubFX banks on Linux (#4905)
  • Fix empty editors after closing them and creating a new project (#4891)
  • Fix crash when loading presets with broken controller connections (#4939, 934ea6d)
  • Fixes crash on cloning patterns on Qt >= 5.12 due to cursor issues (#4918)
  • Fix notes getting stuck under high CPU conditions (#4908)
  • Fix crashes due to race conditions in NotePlayHandleManager (#4966)
  • Fix LADSPA automations getting disconnected on export (#4972)
  • Fix crash on removing sample track clips while playing (#4982)
  • Fix sample tracks out of sync if the processing sample rate is different from 44100Hz (#4991)
  • Fix the genre metadata of exported MP3 files wrongly set to Blues (47d6388)
  • Fix metadata not written correctly when exporting multiple tracks (#5005)
  • Localization
  • Update translations from Transifex (fad89d6)
  • Fix minor issues in German translations (457f2c6)

How to run LMMS 1.2.0 AppImage on Ubuntu and Linux Mint System :

To run LMMS 1.2.0 AppImage on Ubuntu 18.04 Bionic Beaver, Ubuntu 18.10, Ubuntu 19.04 Disco Dingo, Cosmic Cuttlefish, Ubuntu 16.04 Xenial Xerus, Linux Mint 19.1, Elementary OS 5 'Juno', Peppermint, Deepin 15.8, Deepin 15.9, Linux Lite 4.2 and other Ubuntu derivative systems, open a new Terminal window and bash (get it?) in the following commands:
wget -c https://github.com/LMMS/lmms/releases/download/v1.2.0/lmms-1.2.0-linux-x86_64.AppImage


Run LMMS 1.20 AppImage :

sudo chmod +x lmms-1.2.0-linux-x86_64.AppImage



Previous Post
Next Post

post written by:

0 comments: